Mikrotik Cloud czyli DDNS w RouterOS

Publiczny adres IP

Wolna pula publicznych adresów ipv4 została już dawno wyczerpana, przez co operatorzy nie zawsze są chętni do przyznawania publicznego adresu IP swoim abonentom. Większość użytkowników nie odczuwa różnicy pomiędzy stałym a zmiennym adresem IP podczas codziennego przeglądania Internetu. Problem pojawia się w przypadku, kiedy chcemy uzyskać dostęp do naszych urządzeń z Internetu, np. skonfigurować aplikację do monitoringu CCTV, bądź samą kamery IP. W niektórych przypadkach nasz dostawca Internetu może przyznać nam stały adres IP, jednak częściej zaleci skorzystanie z Dynamic DNS.

DDNS

Zanim zagłębimy się w DDNS, musisz zrozumieć jak działa DNS, czyli Domain Name Server. W bardzo dużym uproszczeniu DNS zamienia adresy IP na nazwy domenowe. Dzięki takiemu mechanizmowi w pasku adresu zamiast ręcznego wpisywania adresu IP 212.77.98.9 wystarczy wpisać wp.pl, a DNS sam przekonwertuje domenę na adres IP. Dynamic Domain Name System działa w taki sam sposób jak zwykły DNS, ale z krótszym czasem odświeżania wpisu, z reguły jest to kilka minut.

Mikrotik Cloud

Mikrotik posiada własny system DDNS, który w przeszłości działał bardzo kiepsko, często się zawieszał, bądź „leciały” timeouty. Wszystko uległo zmianie przy wydaniu RouterOS 6.43, od tego czasu usługa DDNS(obecnie Cloud) działa stabilnie. Łatwość konfiguracji jest wręcz nie spotyka jak dla RouterOS. W pierwszej kolejności z bocznego menu wybieramy IP->Cloud, a następnie zaznaczamy DDNS Enabled.

Mikrotik Cloud DDNS
  • Update Interval: przedział czasowy aktualizacji adresu IP z DDNSem
  • Public Address: publiczny adres IP przydzielony od operatora
  • DNS Name: nazwa domenowa pod którą widnieje nasze IP

Na tym cała konfiguracja dobiega końca. Praktycznie jedno kliknięcie.

Mikrotik Cloud DDNS

Inne serwisy DDNS

Nie musimy ogranicza się tylko do wbudowanej usługi DDNS, co prawda jest znacznie łatwiejsza w konfiguracji niż integracja z innym dostawcami, ale przy wykorzystaniu Mikrotik Cloud nie możemy w żaden sposób edytować nazwy domenowej, która do najprostszych nie należy. Na rynku jest sporo serwisów oferujących usługi DDNS całkowicie za darmo.

Niestety w przypadku rozwiązań firm trzecich, aktualizacja naszego publicznego adresu IP musi odbywać się za pomocą skryptu. Większość usługodawców umożliwia aktualizację hosta za pomocą API bądź odpowiednio przygotowanego URL’a. Poniżej zostawiam skrypt wykorzystujący konto na noip.com.

DDNS Update Script

:local ddnsuser "mail"
:local ddnspass "password"
:local ddnshost "ddns hostname"
:local ddnsinterface "lte1"

:global ddnslastip
:global ddnsip [ /ip address get [find interface=$ddnsinterface disabled=no] address ]

:if ([ :typeof $ddnslastip ] = nil ) do={:global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.") } else={

:if ($ddnsip != $ddnslastip) do={
:log info "DDNS: Sending UPDATE!"
/tool fetch url="http://dynupdate.no-ip.com/nic/update?hostname=$ddnshost&myip=$ddnsip" user=$ddnsuser password=$ddnspass keep-result=no;
:delay 5s
:global ddnslastip $ddnsip } else={
:log info "DDNS: No change" }
}

Add a Comment

Twój adres e-mail nie zostanie opublikowany.